Unscheduled Offtime

December 12, Wed
Affected Service: Picturepark DAM - CH03 Cloud Environment
  • Investigating
    We are currently experiencing issues on our CH03 platform and are investigating the cause. Apologies for the inconvenience.

    19:16, Dec 12 CEST
  • Resolved
    The issues for CH03 have been resolved. Apologies for any inconvenience this may have caused you.

    20:14, Dec 12 CEST
Back to current status