CH03: Unscheduled offtime

March 29, Fri
Affected Service: Picturepark DAM - CH03 Cloud Environment
  • Investigating
    Our Picturepark platform CH03 is currently unavailable.

    23:26, Mar 28 CEST
  • Resolved
    CH03 is working again. Apologies for any inconvenience this may have caused you.

    00:09, Mar 29 CEST
Back to current status