Unscheduled Offtime

December 20, Thu
Affected Service: Picturepark DAM - CH03 Cloud Environment
  • Investigating
    We are currently experiencing issues on our CH03 platform and are investigating the cause. Apologies for the inconvenience.

    09:24, Dec 20 CEST
  • Resolved
    The issues for CH03 have been resolved. Apologies for any inconvenience this may have caused you.

    09:36, Dec 20 CEST
Back to current status